web stats
Mirth 3.2 - Connection / ACK issues - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 03-10-2015, 03:35 PM
mcanalld mcanalld is offline
OBX.1 Kenobi
 
Join Date: May 2008
Posts: 26
mcanalld is an unknown quantity at this point
Default Mirth 3.2 - Connection / ACK issues

OS - Linux version 2.6.23.17-88.fc7 (mockbuild@xenbuilder2.fedora.redhat.com)
Java - 1.7.0_75
Mirth Connect - 3.2
Database - psql (PostgreSQL) 8.3.11

Channel Source is setup as:
TCP Listener
All interfaces
Port: 6677 (tried other ports same issue)
Source Queue - On
Response - Auto-generate
Transmission - MMLP
Frame - <VT>{message}<FS><CR>
Mode - Server

Recently upgraded one of our servers from 2.1.1 to 3.2.Been having some very odd issues with TCP Listeners / MMLP. When I deploy channels I'm able to telnet to the ip/port (on a different PC). However Mirth does not show any connections and running - "lsof -n | grep {port}" shows as Listening, but nothing connected. Rebooting the entire server sometimes gets the channels working however once I do a redeploy it instantly breaks. I ended up having to revert back to Mirth 2.1.1 using java 1.6 and works fine.

I also ran - "tcpdump -nn port {port}" then connected via telnet and it shows the connection happening. Again, Mirth shows no connection nor does running "lsof".

When actually trying to send an hl7 message to that channel, from another mirth server, the sending mirth gets timeout waiting for ack, nothing ever received.

I'm so confused what could be happening......
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 07:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation