web stats
Mirth Connect and Java 8 - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 03-26-2014, 05:35 PM
wayneh wayneh is offline
OBX.3 Kenobi
 
Join Date: May 2012
Posts: 102
wayneh is on a distinguished road
Default Mirth Connect and Java 8

Java 8 was released recently and many of you may be wondering whether it is supported by Mirth Connect.

For Mirth Connect 3.0.0 and 3.0.1, unfortunately the answer is no. There is a bug in one of our 3rd party libraries that will cause certain objects to be serialized and deserialized incorrectly in Java 8. For this reason it is imperative that you do not use Java 8 for these versions of Mirth Connect. Even if your server is running on Java 6 or 7, it is important that you do not run the Administrator with Java 8 for these versions, otherwise you may lose information related to your channel or alert upon saving it. In 3.0.2 we will be fixing this issue by updating the library.

Please see the following links for more information regarding the bug.

http://jira.codehaus.org/browse/XSTR-739
http://jira.codehaus.org/browse/XSTR-746

Mirth Connect 2.2.3 and below do not appear to be affected by this bug.

Update
Mirth Connect 3.0.2 has been released and officially supports Java 8. However Java 8 is known to have shipped with bugs intact so be sure to perform your own tests if you are thinking of upgrading.

Last edited by wayneh; 04-16-2014 at 06:33 PM.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 03:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Mirth Corporation