web stats
Failed to launch mirthconnect admin - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 05-27-2014, 12:25 PM
zikal zikal is offline
What's HL7?
 
Join Date: May 2014
Location: Quebec, QC, Canada
Posts: 2
zikal is on a distinguished road
Default Failed to launch mirthconnect admin

Hello,
(yes, newbie). Just starting exploring mirth...

I Did the installation on ubuntu 14.04. Things went well and was able to launch the admin interface. After reboot, I encountered 2 issues:

1- No longer able to go beyond the "webstart" window where there is that green button that says "Launch mirth connect administrator". (I used to have that same windows split in 2 with another green button that says "access secure site". Now, only the "launch mirth connect administrator" that shows up"). So, when I click on the "launch mirth connect administrator", I get the following message:

HTTP ERROR: 503
Problem accessing /webstart.jnlp. Reason:
Service Unavailable

2- When I used the webstart.jnlp file, the login prompt pops up, I put my default username/pwd, but I get the following error message in return:

There was an error connecting to the server at the specified address. Please verify that the server is up and running.

Question:
Any idea about the complete list of services that needs to be up and running in order not to get those error messages? Or is it a completely different problem.

Your help is much appreciated!
Cheers,
Reply With Quote
  #2  
Old 05-28-2014, 04:26 AM
StefanScholte StefanScholte is offline
 
Join Date: May 2009
Location: Netherlands, Harderwijk
Posts: 321
StefanScholte is on a distinguished road
Default

If your rebooted your system
the mirth service probably isn't running

you need to start it
Reply With Quote
  #3  
Old 05-28-2014, 06:38 AM
zikal zikal is offline
What's HL7?
 
Join Date: May 2014
Location: Quebec, QC, Canada
Posts: 2
zikal is on a distinguished road
Default

Quote:
Originally Posted by StefanScholte View Post
If your rebooted your system
the mirth service probably isn't running

you need to start it
Thanks for the prompt response! It worked. Here is what happened:

Started mcservice, it didn't work in the beginning (only the "launch mirth connect administrator" green button that shows up, although I did multiple refreshes), and the service status indicates that it is active (!). On the other hand, the webstart.jnlp login screen fails to log me in; same error message:"There was an error connecting to the server at the specified address. Please verify that the server is up and running".

How it worked then? I just rebooted the machine after having linked mcservice to /etc/rc2.d (not sure if this last step is what made the problem solved) or simply was it because mcservice status wasn't really running although it says "deamon is running" and there was a need to start the service during the machine boot process...
Reply With Quote
  #4  
Old 01-06-2016, 08:55 AM
curt curt is offline
Mirth Newb
 
Join Date: Nov 2009
Posts: 7
curt is on a distinguished road
Default Mirth 3.2.1 Connect: Failed to connect to admin

Started with a running installation of Connect 3.2.1 and Java 7 on Windows Server 2012. On reboot of server with Windows updates cant log in to admin.

When you Launch Administrator and enter credentials you get the message: There was an error connecting to the server at the specified address. Please verify that the server is up and running.

When you restart Mirth Connect the Mirth icon in the system tray displays: The Mirth Connect service could not be started.

Mirth Connect is running but I can not log in.

I have updated to Java 8, turn off TSL1.2 in properties, added environment variable EXEC4J_JAVA_HOME for java path.

Mirth Connect error log is clean.

I have review the various threads on this issue and cant find anything else to do to fix this.

Any suggestions,
Thanks
Reply With Quote
  #5  
Old 01-06-2016, 09:42 AM
narupley's Avatar
narupley narupley is offline
Mirth Employee
 
Join Date: Oct 2010
Posts: 7,126
narupley is on a distinguished road
Default

Is the mcservice process running at all? As a test, try running mcserver.exe directly from the installation directory, and see if any errors appear.
__________________
Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

Nicholas Rupley
Work: 949-237-6069
Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


- How do I foo?
- You just bar.
Reply With Quote
  #6  
Old 01-06-2016, 10:04 AM
curt curt is offline
Mirth Newb
 
Join Date: Nov 2009
Posts: 7
curt is on a distinguished road
Default

Yes, when I ran it from the install directory is complained that Mirth: http.port port is already in use :8080
Same for :8443
Reply With Quote
  #7  
Old 01-06-2016, 10:17 AM
narupley's Avatar
narupley narupley is offline
Mirth Employee
 
Join Date: Oct 2010
Posts: 7,126
narupley is on a distinguished road
Default

Quote:
Originally Posted by curt View Post
Yes, when I ran it from the install directory is complained that Mirth: http.port port is already in use :8080
Same for :8443
That would indicate that the process is already running, though I'm not sure how it got into that state if the Windows service says that it's stopped. Find the process and kill it, and try again.
__________________
Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

Nicholas Rupley
Work: 949-237-6069
Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


- How do I foo?
- You just bar.
Reply With Quote
  #8  
Old 01-06-2016, 10:24 AM
curt curt is offline
Mirth Newb
 
Join Date: Nov 2009
Posts: 7
curt is on a distinguished road
Default

Found it in task manager along with mcmanager.exe. Ended task mcserver.exe. Then double clicked on mcserver.exe in install folder. Same error messages.

Mirth Connect is running processing transactions, i just can't log into it.
Reply With Quote
  #9  
Old 01-06-2016, 11:01 AM
narupley's Avatar
narupley narupley is offline
Mirth Employee
 
Join Date: Oct 2010
Posts: 7,126
narupley is on a distinguished road
Default

Quote:
Originally Posted by curt View Post
Found it in task manager along with mcmanager.exe. Ended task mcserver.exe. Then double clicked on mcserver.exe in install folder. Same error messages.

Mirth Connect is running processing transactions, i just can't log into it.
Did you somehow start up multiple instances of MC? Or, do you have anything else on the box that is listening on those ports already? 8080 and 8443 are common for Apache Tomcat for example.
__________________
Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

Nicholas Rupley
Work: 949-237-6069
Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


- How do I foo?
- You just bar.
Reply With Quote
  #10  
Old 01-06-2016, 11:38 AM
curt curt is offline
Mirth Newb
 
Join Date: Nov 2009
Posts: 7
curt is on a distinguished road
Default

This machine is setup to just run Mirth Connect and it has for successfully for quite some time.

Missed an instance of mcservice.exe down in background processes; ended it.

How when I double click on mcservice.exe in install folder the command window pops up clean. No Errors, no messages.

With no instance listed Task manager, I used Connect Server Manager to start Mirth Connect Service and saw the same error message pop up in the system tray and I can't log in. I then ended the background task in the task manager.

Now what should I do.
Reply With Quote
Reply

Tags
mirthconnect, server

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 11:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Mirth Corporation