Mirth Community

Mirth Community (http://www.mirthcorp.com/community/forums/index.php)
-   Support (http://www.mirthcorp.com/community/forums/forumdisplay.php?f=6)
-   -   DICOM Listener Question (http://www.mirthcorp.com/community/forums/showthread.php?t=10690)

atibbits 05-21-2014 08:25 AM

DICOM Listener Question
 
How do you find out what AE Title to use for Mirth? I am trying to set up a DICOM Listener and our sending machine is asking for an AE Title. This is my first attempt at DICOM via Mirth so any suggestions would be GREATLY appreciated!!

narupley 05-21-2014 08:30 AM

By default the AE title is blank on the DICOM Listener settings, meaning that requests with any title are accepted. If you want to restrict requests to a single title, you can specify one and then notify the sending machine to use the same title.

atibbits 05-21-2014 08:35 AM

So, basically if I leave it blank in the DICOM Listener settings in Mirth I will not have to worry about what the sending machine has in it for an AE title?

narupley 05-21-2014 08:35 AM

Quote:

Originally Posted by atibbits (Post 39739)
So, basically if I leave it blank in the DICOM Listener settings in Mirth I will not have to worry about what the sending machine has in it for an AE title?

Yep, that's the idea.

atibbits 05-21-2014 08:37 AM

I like that idea! Thanks!

atibbits 05-27-2014 09:04 AM

Need Help Receiving DICOM
 
I am having the worst time receiving DICOM. I am wondering if I am missing something on setting this up? I just set up a channel as a DICOM listener and I assigned it a port. I left the Application Entity (AE Title) blank so it would be able to accept any incoming AE Title. Then, our Ultrasound tech puts in our IP/Port and then attempts to send to us, but she keeps getting denied. She is able to ping mirth from the machine though, but she cannot send. I haven't changed any of the defaults in the DICOM listener settings.


Any thought on what I should do or what I might be missing?

narupley 05-27-2014 09:31 AM

Quote:

Originally Posted by atibbits (Post 39865)
I am having the worst time receiving DICOM. I am wondering if I am missing something on setting this up? I just set up a channel as a DICOM listener and I assigned it a port. I left the Application Entity (AE Title) blank so it would be able to accept any incoming AE Title. Then, our Ultrasound tech puts in our IP/Port and then attempts to send to us, but she keeps getting denied. She is able to ping mirth from the machine though, but she cannot send. I haven't changed any of the defaults in the DICOM listener settings.


Any thought on what I should do or what I might be missing?

Hmm well, I thought that leaving the AE on the DICOM Listener settings would allow it to accept any AE on an incoming request, but maybe that's not true. Have you tried putting in the correct AE in the DICOM Listener settings? You need to find out what the client is sending and use that.

atibbits 05-27-2014 09:41 AM

That's probably the only thing I hadn't tried. I will go give that a shot!

atibbits 05-27-2014 11:18 AM

Well, that was the issue!! Yay, It works now!

Now for testing I have been trying to send the DICOM image to a file. I am unable to get the files to open. I am sending them out as binary. Is there a trick to get that to work? So far, I have tried jpg and pdf with no luck.

narupley 05-27-2014 11:31 AM

Quote:

Originally Posted by atibbits (Post 39876)
Well, that was the issue!! Yay, It works now!

Now for testing I have been trying to send the DICOM image to a file. I am unable to get the files to open. I am sending them out as binary. Is there a trick to get that to work? So far, I have tried jpg and pdf with no luck.

More information is needed. What exactly are you doing?


All times are GMT -8. The time now is 09:20 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation