Mirth Community

Mirth Community (http://www.mirthcorp.com/community/forums/index.php)
-   Support (http://www.mirthcorp.com/community/forums/forumdisplay.php?f=6)
-   -   Mirth Connect Administrator Launcher - JNLP error Launching (http://www.mirthcorp.com/community/forums/showthread.php?t=221831)

R3dbv11 11-26-2019 07:25 AM

Mirth Connect Administrator Launcher - JNLP error Launching
 
1 Attachment(s)
Hi all. I am a person who has recently entered the world of Mirth Connect professionally.

For a year I kept a version of mirth connect on my laptop to practice a course, but now I have trouble opening the "Mirth Connect Administrator Launcher "and is my tool to manage my test channels.

When you select a connection and press "Launch", a "Requesting JNLP main" message appears, and the second an error message appears

("Error downloading / verifying code base"), with extensive detail that begins with the following:

The payload of the HTTP request cannot be retrieved. URI: http: // localhost: 8085 / webstart java.lang.Exception: The HTTP request payload cannot be retrieved. URI: http: // localhost: 8085 / webstart

Look at the details in the forum.txt file attached to this message.

The data of my installation are the following:
  • Java versión: 8, Actualization 231 (Compilation 1.8.0_231-b11)
  • Mirth Connect Server versión: 3.7.0.
  • Mirth Connect Administrator Launcher version: 1.0.0.
  • Mirth Connect Server Manager: works and restart service.


I ask for help. I install mirth in another PC test and it works well, the problem is with my laptop.

I have Windows 8.1 64 bits, fully updated.

Thank you.

Jean González, from Argentina.


P.S. Sorry for my bad english

agermano 11-26-2019 07:39 AM

Are you sure the server is running and listening on that port? 8085 is not the default.

stormcel 11-26-2019 11:25 AM

check your firewall settings. windows defender settings etc. It sounds like a permissions problem. as in the 'connection refused' message.

R3dbv11 11-26-2019 01:07 PM

Windows Defender: the application is disabled.
Windows Firewall is disabled.
What is the default port? I don't remember changing it.

I have the Avast antivirus, but I have not made changes in the last months, and I have added Mirth folders as exceptions, no solution

Thanks for the support

agermano 11-26-2019 02:07 PM

The default http port is 8080 and https is 8443

R3dbv11 11-28-2019 10:22 AM

Quote:

Originally Posted by agermano (Post 270758)
The default http port is 8080 and https is 8443


I did a test at the following addresses using the "Mirth Connect Administrator Launcher", and the results are the same.

http://localhost:8080/webstart
https://localhost:8443/webstart

I uninstalled + installed mirth and JRE 8, and the error continues.

The problem is with my development notebook (Windows 8.1), but I would like to solve it because it could happen in the production environment

Thanks for the support

stormcel 11-29-2019 02:05 PM

are you able to see those pages that mirth advertises in your browser?
i.e. http://localhost:8080/webadmin/Index.action

jackwhaines 11-29-2019 02:14 PM

R3dbv11, if you get truly desperate, you are welcome to setup a call with me at https://calendly.com/jackhaines and I'll try and help you.

R3dbv11 12-03-2019 06:09 AM

Quote:

Originally Posted by stormcel (Post 270806)
are you able to see those pages that mirth advertises in your browser?
i.e. http://localhost:8080/webadmin/Index.action

that URL points to a Jira web service installed in my Notebook


I continue to analyze the problem.

R3dbv11 12-03-2019 06:11 AM

Quote:

Originally Posted by jackwhaines (Post 270807)
R3dbv11, if you get truly desperate, you are welcome to setup a call with me at https://calendly.com/jackhaines and I'll try and help you.


My purpose now is to learn, but if you want to help us we can schedule a call. thank you very much.


All times are GMT -8. The time now is 03:32 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Mirth Corporation